Server Status • Creed Servers Int. - Dedicated Machine is Currently Offline! – Incident details
Get updates
Discord
Webhook
Get updates
Dark mode
All systems operational
Dedicated Machine is Currently Offline!
Resolved
Major outage
Started 10 months ago
November 28, 2025
Lasted 15 minutes
November 28, 2025
10:03
10:18 AM
UTC
Affected
Dedicated Machine
Major outage from 10:03 AM to 10:18 AM
Updates
Resolved
November 28, 2025 at 10:18 AM
UTC
Resolved
November 28, 2025 at 10:18 AM
UTC
Dedicated Machine are back up and running! Thanks for your Patience!
Investigating
November 28, 2025 at 10:03 AM
UTC
Investigating
November 28, 2025 at 10:03 AM
UTC
Dedicated Machine are currently down at the moment. We are investigating!
UTC
UTC
UTC
UTC
UTC