Server Status • Creed Servers Int. - Dedicated Machine is Currently Offline! – Incident details
Get updates
Discord
Webhook
Get updates
Dark mode
All systems operational
Dedicated Machine is Currently Offline!
Resolved
Major outage
Started 13 days ago
Lasted 3 minutes
Affected
Dedicated Machine
Operational from 11:56 AM to 11:56 AM, Major outage from 11:56 AM to 11:58 AM
Updates
Resolved
November 28, 2025 at 11:58 AM
Resolved
November 28, 2025 at 11:58 AM
Dedicated Machine are back up and running! Thanks for your Patience!
Investigating
November 28, 2025 at 11:56 AM
Investigating
November 28, 2025 at 11:56 AM
Dedicated Machine are currently down at the moment. We are investigating!